SSブログ

Firefoxで未対応のアドオンを使う [PC]

Firefox『3.5』にアップグレードしましたが、
使っている中でやはりタブに関するアドオン「Tab Mix Plus」が
未対応のままではブラウジングがまともに出来ないため、どうにな出来ないかと調べてみました。


Firefoxのオプションでは変更出来ない箇所まで手を入れることが出来る「about:config」を操作し、
未対応のアドオンを無理やり使ってみたいと思います。

その際、セキュリティを無効にするため脆弱になってしまいます。


アドレスバーに「about:config」を打ち込むと、
「動作保障対象外になります!」といアラートの後に詳細設定画面に進むことが出来ます。


右クリックし、新規作成(W)→真偽値(B)に進み
「extensions.checkCompatibility」と
「extensions.checkUpdateSecurity」と2回新規で作成します。

addons-shingi.gif
「about:config」上で右クリック

addons-extensions.gif
「extensions.checkCompatibility」を入力

「真偽値を入力してください」のダイアログにて値「false」でOKボタンを押す。

「extensions.checkCompatibility」
  拡張機能でバージョン整合性チェックをしなくなる。
「extensions.checkUpdateSecurity」
  セキュリティを無効にします。


その後Firefoxを再起動すると、
『3.0』時代に入れていた「Tab Mix Plus」が
Firefox 3.5には対応していません。のメッセージがありながら有効化されました。

tabmixplus.gif
Firefox 3.5には対応していません。

「Tab Mix Plus」自体は動いているようですが、設定が初期に戻っているようで、
Firefoxのメニューからツール(T)→Tab Mix Plusのオプションに進み設定は
『3.0』の頃に設定した状態ですが、なぜか何も利いてません。

チェックボックスをON→OFF→ONなどして
「OKボタン」を押すと以前のような動きをしてくれるようになりました。


セキュリティ的に?が付きそうですが、
「Tab Mix Plus」がどうしても使いたいため仕方が無いですね。

ブラウジングが快適になった。


■参考サイト

Mozilla Re-Mix: Firefox3 Beta版に対応していないアドオンを強引に ...
http://mozilla-remix.seesaa.net/article/84338863.html

■リンク

Tab Mix Plus
https://addons.mozilla.org/ja/firefox/addon/1122

about:config と user.js による Firefox のカスタマイズ - えむもじら
http://level.s69.xrea.com/mozilla/index.cgi?id=aboutconfig
タグ:Firefox
nice!(0)  コメント(0) 
共通テーマ:パソコン・インターネット

nice! 0

コメント 0

コメントを書く

お名前:[必須]
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

この広告は180日新規投稿のないブログに表示されます